
MatchMove

Digital Visual Effects, Spring 2014

Winble  2014/05/20



WorkFlow

• Input 

– Video – CGI Animation
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WorkFlow
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• Output

– Composite Video



WorkFlow
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Setting

• Blender
– Version: 2.70a

– Operating System
• Windows XP/Vista/ 7 / 8  32/64 bits, Linux, Mac OS X

– Web Site: http://www.blender.org/

• Voodoo
– Version: 1.2.0 beta 

– Operating System
• Windows 95/98/NT/2000/Me/XP/Vista/7, Linux

– Web Site: http://www.digilab.uni-hannover.de/

• Other Options
– Free: Blender + ICARUS

– Pay: boujou + 3D Max, boujou + Maya, ...
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http://www.blender.org/
http://www.digilab.uni-hannover.de/


Recipe: Get Image Sequence

0.   Open Blender

1. Add Video File
– Change Window Type to Video Sequence Editor

– Select Add → Movie

2. Render Images
– Choose Render Mode

– Frame

• Set frame size and resolution

• Choose output file type (Targa)

– Time interval → Select start and end of the sequence

– Choose output directory

3. Click Animation button
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Step 0 : Blender Interface
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Step 1 : Add Video File

Click here to change window type

Change to Video 
Sequence Editor
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Step 2-1 : Add Video File

Add → Movie
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Step 2-2 : Add Video File

Select input video file

Add video file

Select file directory
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Step 2-3 : Add Video File

This is the sound track. Since we only need images 
for feature tracking, you can choose to remove it 
here, and add it back at the video editing stage!

11

Click “Delete” button



Step 2-4 : Add video file

Right-click to Drag the strip to the “1st Frame” in Layer 1
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Step 2-4 : Add video file
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Choose output 
file type “Targa” Set output directory

Set Frame size, Resolution, Frame 
Range & Frame rate

Produce!

Input video

Input Audio



Recipe: Calibration

0.   Open Voodoo

1. Open Image Sequence

– Select File → Open → Sequence

– Select the first frame

– Select Move Type “Free Move”

2. Track → Click Track button

3. Export Python Script

– Select File → Save → Blender Python Script

– Save .py file 
• Choose File type “Blender 2.5x and higher (*.py)”
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Step 1-1 : Choose Sequence

File → Open → Sequence 
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Step1-2 : Choose Sequence

Choose “free move”

Select 1st frame
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Note!!!
1. “free move” is for general moving conditions
2. “rotation (camera on tripod)” is for the 

special case with only the rotation

Avoid unrecognized path



Step 2-1 : Track

Track
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Step 2-2 : Track

Process 
Progress
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Step 3-1: Export Python Script

File → Save 
→ Blender Python script
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Choose File type “Blender 
2.5x and higher (*.py)”



Note

• I meet problems on Voodoo
– Voodoo sometimes crashes due to

• Too large file size

• Too complicated tracking situation

– The tracking result is not satisfying

• Solution

– Split your video into smaller clips

– Use Blender (need to give camera parameters)
http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.70
/Motion_Tracker

http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.70/Motion_Tracker


Recipe: Import 3D Motions

1. Open Blender

2. Delete Default Objects

– Choose the object and click “Delete”

3. Load Python Script

– Change Window Type to Text Editor

– Select Text → Open Text Block

– Select io_import_voodoo_camera_fix.py and Run Script 

– Import voodoo_camera to run previous .py file

4. Adjust Rendering Property
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Recipe: Import 3D Motions

5. Load Background Images:
– Change Window Type to 3D View

– Select View → Cameras → Set Active Object as Active 
Camera

– Load background images

– Set the video parameters of background images

– Change the view 
• View → View Persp/Ortho

• View →  Front

– Check any frame and adjust the opacity of background 
images 

6. Load models & editing their motions in the video!
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Step 1: Delete Default Objects

Click “Delete” to erase
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Press “a” twice to 
select all objects



Step 2-2 :  Load Python Script

Text → Open Text Block

Choose “Text Editor”
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Step 2-3 :  Load Python Script

Select  io_import_voodoo_camera_fix.py   http://ppt.cc/BNkt

Run Python Script
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http://ppt.cc/BNkt


Step 2-4 :  Load Python Script

File → Import → 
Voodoo camera
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Choose 
previous .py file



Step 3-1 : Load Background Images

Select voodoo_render_cam
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Back to 3D View



Step 3-1 : Load Background Images

Set Active Object as Camera 
to see the video view
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Step 3-3 : Load Background Images

Click the “+” View → Propertiesor
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Step 3-3 : Load Background Images

Tick off “Background Images”, click “Add Image”
Then Open Image Sequence/ Video Clip
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Enable“Auto
Refresh”



Step 3-6 : Load Background Images

Use any frame to check 
background image

You can adjust background image’s 
Opacity, Scale & Position

31



Step 5-1 : Load Models

File → Import  
→ “Model Type”
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Step 5-2 : Load Models

To use the model as a “single 
object” instead of many “small 
groups(components)” ,you can 

close the group options
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Step 5-2 : Load Models

Model split by groups
(for finer operations)
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Step 6-1 : Set Keyframes

Object → Animation → Insert Keyframe…
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Set the motions of your model !



Step 6-2 : Set Keyframes

Model parameters and 
corresponding lock in keyframe
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Choose Object Mode

Lock the parameters in keyframe

Choose keyframe



Step 6-3 : Set Keyframes
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You can use
Object → Motion Paths → Calculate Paths 
to see the motion path of models

Motion Path

Time point of Keyframes



Step 6-4 : Set Keyframes
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Some notes

 Different camera views are helpful
• Fine adjust 3D position & shape

 Preview is your good friend
• Ensure your model condition 

shown in that frame 

 Don’t forget the light (lamp)
• Preview won’t show the lighting
• Avoid model “in the dark”

 Unstable model motion
• Set more keyframes
• Split fast-moving video into more 

small-period clips



Recipe: Compositing

1. Add Image Sequence

– Change Window Type to Video Scene Editor

– Select  Add → Images and select all images

– Drag the strip to the “1st Frame” in Layer 1

2. Add Scene

– Select Add → Scene

– Drag the scene strip to the “1st Frame” in Layer 2

3. Set Scene

– Change scene property to “Alpha Over”

– Set frame and video parameters

4. Click Animation
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Step 1 : Add Image Sequence

Choose “Sequence Editor”

Add → Image/Movie
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Drag the strip to the “1st Frame” in Layer 1
(Right click and drag, left click to set)



Step 2 : Add Scene

Add → Scene → Scene
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Drag the scene strip to the “1st Frame” in Layer 2



Step 3-1 : Set Scene

Chose Node Editor

Choose display/edit 
node tree &

Tick off “Use Nodes”
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Step 3-2 : Set Scene

Add Image/Movie Set Image Sequence
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Add Z Combine



Step 3-3 : Set Scene

Adjust the 
step lines
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Set image Z value
(see the memo below)

Layer1
Layer2



Step 3-4 : Set Scene

Press “Render” or Select the “UV/Image 
Editor” to check the rendering result
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Step 3-4 : Set Scene

Animate the final result!
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Set video Resolution, Frame 
Range (time) & Frame Rate

Select output directory 
& Video type



Example

• Life of Pi and R.I.P.D Tracking and MatchMove
– https://www.youtube.com/watch?v=lE3QwDfoyp4

• NTU VFX 2011 Assignment #3
– https://www.youtube.com/playlist?list=PLDBC5F12DD815090D

• NTU VFX 2012 Assignment #3
– https://www.youtube.com/playlist?list=PLiioR5ew-

ZqsFuya7pwt9Y0eopsR8KpmI

• NTU VFX 2013 Assignment #3
– https://www.youtube.com/playlist?list=PLiioR5ew-

Zqs7_Q72a8AMQPaJ77LZSUyW
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https://www.youtube.com/watch?v=lE3QwDfoyp4
https://www.youtube.com/playlist?list=PLDBC5F12DD815090D
https://www.youtube.com/playlist?list=PLiioR5ew-ZqsFuya7pwt9Y0eopsR8KpmI
https://www.youtube.com/playlist?list=PLiioR5ew-Zqs7_Q72a8AMQPaJ77LZSUyW


Reference

• Blender 

– Official website

http://www.blender.org/

– 2.70 release log

http://wiki.blender.org/index.php/Dev:Ref/Release_Notes
/2.70

– 2.70 New Features
http://www.blender.org/features/2-70/

– Tutorial

http://www.blender.org/support/tutorials/

– 2014 Demo
https://www.youtube.com/watch?v=EJed22ShxLc
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http://www.blender.org/
http://wiki.blender.org/index.php/Dev:Ref/Release_Notes/2.70
http://www.blender.org/features/2-70/
http://www.blender.org/support/tutorials/
https://www.youtube.com/watch?v=EJed22ShxLc


Reference

• Blender

– Blender 2.70 Camera Tracking
http://vimeo.com/87658924
http://www.youtube.com/watch?v=mQY0EtYniqA

– Match Moving Tutorial in Blender
https://www.youtube.com/watch?v=GzL33T1CNgY

– Basic video tutorial
https://www.youtube.com/results?search_query=blender
+tutorial+beginner

– Basic video tutorial for Blender and Voodoo [Older vision]
http://www.youtube.com/watch?v=kPZbtKQ1a4g
http://www.youtube.com/watch?v=sO4kmT-n3lU
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http://vimeo.com/87658924
http://www.youtube.com/watch?v=mQY0EtYniqA
https://www.youtube.com/watch?v=GzL33T1CNgY
https://www.youtube.com/results?search_query=blender+tutorial+beginner
http://www.youtube.com/watch?v=kPZbtKQ1a4g
http://www.youtube.com/watch?v=sO4kmT-n3lU


Reference

• Voodoo

– Python problem between Voodoo and Blender 
appear again for different versions!!!!!

• Voodoo camera Import for v2.68 ~ v2.70
(io_import_voodoo_camera_fix.py)
http://ppt.cc/BNkt

Voodoo document website
http://0rz.tw/c2ceR

– CINEMA 4D + VOODOO – TUTORIAL
http://www.youtube.com/watch?v=JWlW7ay0yi4
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http://ppt.cc/BNkt
http://0rz.tw/c2ceR
http://www.youtube.com/watch?v=JWlW7ay0yi4


Reference

• Other Resources

– K-Lite Codec Pack

• Mega, Full, Standard and Basic
http://www.codecguide.com/download_kl.htm

– Video Editing Tools

• 威力導演、繪聲繪影、 …

• Sony Vegas, Adobe After Effects, Premiere, …

– Sound/Music Editing Tools

• Adobe Audition ( original cooledit ), Goldwave, … 
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http://www.codecguide.com/download_kl.htm


Thank  you 

for your attention!
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Step 4-1 : Adjust Rendering Property
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To avoid 
rendering the 
feature point 
cloud in your 

result



Step 4-2 : Adjust Rendering Property

Cancel the 
Renderability of 

the feature 
point cloud
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