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Flowchart
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CGlLANnIMation

Matchmove is a technique of estimating
camera parameters from an input video
sequence so that computer generated
Imagery (CGIl) could be seamlessly
Inserted into the sequence.
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Flowchart (detailed) ™~
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DIIVFX

Environment Setting

e Blender

- Version 2.6.2 http://download.blender.org/release/
- Using version 2.6.6 might get error while running python scripts

e Voodoo
- Version 1.2.0 http://www.viscoda.com/index.php/en/voodoo-download

e Other options
- Free: Blender + ICARUS
- Pay: boujou + 3D Max, boujou + Maya, ...



Recipe: Get Image Sequenc@

Open Blender

Load video file:

- Change window type to “Video Sequence Editor”
- Select Add —Movie

- Put the strip in Layer 1

Do sequence:

- Frame
e Set number of frames and resolution of frames
e Choose output file type (Targa)

- Time interval: select start and end of the sequence
- Choose output location

Click “Animation” button



Step by Step: Get Image Sequence
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Step by Step: Get Image Sequenc@

% Mavie Clip Editor

'] 2. Change to Video Sequence Editor
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Step by Step: Get Image Sequenc

Select
Add -2 Movie

G.

Add video




Step by Step: Get Image Sequenc@

Select input video



Step by Step: Get Image Sequenc@

1. Delete unnecessary layer (audio)

2. Right-click to drag the strip to the “1st Frame” in Layer 1

..... = = e

G: = (DN«  stat:l  » | Encl: 250 CE Y (s | [ vl o] o Sync = ol e A [

Edit layers (Right click and drag, left click to set)
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Step by Step: Get Image Sequenc@

1. Set
a. Resolution
b. Start/End Frame
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2. Set file types to Targa(TGA) » 3. mOd'Zy output
7 s | lfgg_gry

B il B W

Do video setting 11



Step by Step: Get Image Sequenc@

Finish!
You can find the image sequences in ‘

output directo
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video and
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11 16 Mitchell-Metravali .

Back to flowchart
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Recipe: Calibration

e Open Voodoo

e Open image sequence:
- Select File - Open - Sequence
- Select the first frame
- Set Move Type to “free move”

e Track:
- Click Track button

e Export Python script:
- Select File - Save - Blender Python Script
- Save .py file (Blender 2.5x and higher)
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Step by Step: Calibration™"

5 Voo — e
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¥y |

camera tracker | |
Vi

0

Use Voodoo to load image sequence
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Step by Step: Calibration

[ Voodoo r el
[File ] View Help 1. Select the first frame
Open » Sequence Ctrl+5 .
sE b Ini:ali: = (eX. 0001 °tga)
Quit  Ctrl+Q [} Sequence Select o,

I Divectory:  CiTsrsEevincomenDesktopdTRI T201 Linpat_sequence Buose

File Template: #### toa Help

otart: 1 End: 210

!

Step: 1 Totl: | 210

Interlace: Move Tpe:

2. Select “free move”

(general moving of camera)
0 Wa<ED>D - © L sent

= ifree MoveE

Choose and set sequence
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Step by Step: Calibration

o_RandSampling: :FindParameterSet: SUCCESSFUL
’ after 1080 searchs, select bhest one, ratio (supported/input correspond|
lences): 1.000000 <(48,48>

o_RandSampling::MarkSet: 48 corrs, 48 supported, B not supported
IBOOO0O0000000000006%  o_CTrackMgr: :ComputeDetection

el omputeCorrespondenc".-. e -'! ! = =@ 53

o_FCorrelatorKLT::Compute: Tracking 68 features in a 32[ o
o_FCorrelatorKLT : 65 features successfully tr:
o_FCorrelatorKLT::Compute: Attempting to replace 935 fe lﬁ Progressofl'l:::..ﬁ_ﬁ?
by 248 image... I
Notice: o_FCorrelatorKLT::Compute: 4 features replaced.
Notice: o_FCorrelatorKLT::Compute: found 65 corrs. (16888 fp of
B8 fp of img no. 34>
Notice: FOOOOO06000000000006%  o_CTrackMgr: :ComputeOQutlierElimir
| FEIEIEIIEIEHIIEIIEE

Notice: o_RandSampling: :FindParameterSet: SUCCESSFUL
Notice: after 1080 searchs, select bhest one, ratio (supported/i
ences)>: 1.800880 <(65/65>

Notice: o_RandSampling::MarkSet: 65 corrs. 65 supported. B not ) L A - “ ”
Notice: FOOO0O0000000000006%¢  o_CTrackMgr: :ComputeCameraEstimat A : b ]C rac utton

B

33 [¢d)[«l)[ <> - b St 1 End: 210 Skp: 1 Track

| C:/Users/Kevincosner/Desktop/CSIT2011/input_sequence/0034.tga - ONLY FOR NON COMMERCIAL USAGE

P —— \\
Tracking features
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Step by Step: Calibration™"

Back to flowchart

Select p
i File > Save - Blender Python Script

[&]» View Help ' SeIeCt
Open i m . -S.elect.Blenderv...‘ “ Blender 20 5X

Save ’ 1 3D Max Script
s N higher”
e -

Quit Crl+Q | Blender Python Script
| Blender 2 5xcand higher
[ 0K ] [ Caneel ]

Lightwave 3D \H‘\/
Maya Script
Textfile —

Softimage 3D|XSI

CAHV Cameras

Feature Points

SIFT Descriptors

Export 3D Objects

29 (<< -

AR~ ]

motanrans 9@ @CE “Export all”

Export all
[] Limit the number to | 1500

| ok || Cancel

Save results to “Blender Python Script”

-
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Recipe: Import 3D Motions ™

e Open Blender

e Delete default objects
- Choose the object and press “Delete”

e Load Python Script
- Change Window Type to “Text Editor”
- Select Text - Open Text Block
- Select the .py file (exported from Voodoo)
- Click “Run Script”

(cont.)
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Recipe: Import 3D Motions ™™

(cont.)

e Load Background Images
- Change window type to “3D View”
Select View - Cameras - Set Active Object as Active Camera
Load background images
Set the parameters of background images

Change the view
e View - View Persp / Ortho
e View - Front

e Load models and edit their poses/motions in the video
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Step by Step: Import 3D Motiofis ™

Delete default objects




Step by Step: Import 3D Motiofis ™
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Change window
type to
“Text Editor”

% Select the Python script
Load python script  exported by Voodoo
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2. Return to “3D View”
. 1. Press “Run Script”

Run script




“voodoo_render_cam”

X

Select Voodoo camera




Toggle Full Screen Ctrl Up Arrow
Toggle Quad View Ctrl Alt ©

Duplicate Area irto New Window
i

Playback Animation Alt A =)

"2~ woodoo_render_cam

View All Home
View Selected Nurmpad . ;

> 1 C——
View Global/Local MNurnpad LJ

Show All Layers

4
Zoom Border... Shift B
Clipping Border... AltB
Align View

g (s
Mawvigation
4

View Persp/Ortho Nurmpad 5

£ »
»
¥ >
Image Editor
Cameras
il Y: 10.0806 =
Left Ctrl Numpad 3 - N

Right Nurnpad 3 Tu rn O n

Back Ctrl Numpad 1 Render Presets
Front Numpad 1 [ P ro S E—
Bottomm Ctrl Nurmnpad 7 |« vioeo ¢ |
Top Numpad 7 y

Camera Numpac

Tool Shelf
Add anev ackground image
I
o

Toggles the properties panel display

L KR

Show Property Panel

v
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Step by Step: Show Background Imag
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Step by Step: Show Background Imagé@

e o€t
1. Number of frames
2. Start frame (1)

Select

c‘lma e Se Uence”
: ; Refresh”

. — N T e e T o o T e S
Always refresh image on frame chan

Change
background type
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Step by Step: Show Background Image

Digi
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All Scenes s |2k

Set
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Step by Step: Show Background Imag&@

Ctrl Up Arrow

Horme
Home Mumpad .
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rm Border...

Clipping Border...
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Ctrl Nurmnpad 3
Numpad 3 Murnpad 3

Ctrl Nurnpad 1

Top
Camera
B Tool Shelf
B Properties
(=] ode —

= v

N
® Object Mode v

e %

O sert1 -]

Moo
v €50

Pl |

Set view




Step by Step: Show Background Ima T

Ctrl Up Arrow
Ctrl Alt Q

Duplicate Area into New Window

Playback Animation Alt A
View All Home
View Sel 2 Numpad .
View Global/Local Numpad /

Show All Layers

Zoom Border...

Clipping Border...

Align View

Navigation

View Persp/Ortho Numpad 5

e G Bimetoes 5 HEIEE Set the active object as the active camera for this view or scene
Right Numpad 3
Back Ctrl Numpad 1
Front Numpad 1
Bottom Ctrl Numpad 7

Top Numpad 7

Camera Numpad S et

B Tool Shelf

S e Cameras > Set Active Object as Camera

Set active camera
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Check background Back to fIOWChart
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U ETEEEEER C TR senderRender 3D
Ctrl N IV
Ctrl O
Open Recent... Shift Ctrl O
'@ Recover Last Session

Recover Auto Save...

— 53VE Ctrl S
Save As... Shift Ctrl S
Save Copy... Ctrl Alt S

S Bl User Preferences..  Ctrl AltU
Save User Settings Ctrl U
Load Factory Settings

Link Ctrl Alt O
Append Shift F1

r B COLLADA (.dae)
Export Motion Capture (.bvh)
External Data Scalable Vector Graphics (.svg)
Stanford (.ply)
Stl (.stl)
3D Studio (.3ds)

e U quit

Select
pessteiy File > Import >Wavefront
(you can also use other file format)

X3D Extensit

Load models




Step by Step: Load Models™™

You can set the transform of your
objects to edit their positions and

< Overwrite
© : d EEBIFIE vo syne | B2 N

Lo sl c | Endi2i0 L0 1 R

Set poses / positions for models
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LA
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Fine tunmg You can drag here to see whether your tumng is
correct or not
(is the object located at the correct position?)




Step by Step: Set Animati&i"

1. Select the frame that you want to insert
a key frame
2. Select
Object &> Animation - Insert Keyframe..
3. Repeat multiple times

\\\\\

% [oEmER[aEmERl g
EEEEE SRR

(_sertr [ ee20 JC 1 JRRIQIID[

Frame 1

S No Sync 1 E
I Re
al I l e 8‘ ) Undo &
r ® 0b) o Bl o ¢ |pinnnasass g RIE o |3

(o]

© BT L ——

Set keyframes



-2 Blender* [C:\Users\Ke

@4 e ST . 3 5 d  BlenderRender ¥ B

Camera Persp A All Scenes

You can fine-tune the
E transformation of objects

Join

Game

in a keyframe here

Constraints
Group
Track
Parent
Make Single User

Local

Dupli-Face

ctr L
@ Proxy. Ctrl AltP

Delete Delete All Views ¥
Duplicate Linked AltD
Duplicate Objects  Shift D

Movie Clip
a

P Image Sequ ¥ a
Snap shift S Delete Keyffar | ot Keyframes for specified Keying Set, with menu of available Keying Sets if undefined Ll o

Change Keyinc (=] cev0001.toa| )

Apply Ctrl A
Clear Bake Action

Mirror

Transform

Undo History Ctrl AltZ D )
Redo Shift Ctrl Z

Undo iz

@ Object Mode % g 3By P . 4 HH ( 15 = Frames Verts  Faces  Group

Fine tuning Back to flowchart
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Recipe: Compositing

Add image sequence
- Change window yype to “Video Sequence Editor”
- Select Add - Images and select all images
- Drag the strip to the “1st Frame” in Layer 1
Add scene
- Select Add - Scene
- Drag the scene strip to the “1st Frame” in Layer 2
Set Scene
- Change scene property to “Alpha Over”
- Set parameters of frame and video
Click “Animation”
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Compositing"

B Python Console
& File Browser

@ Info

[E User Preferences
:_: Outliner

= Properties

;:‘ Logic Editor

=) Node Editor

B Text Editor

2 Movie Clip Editor
= Uvfimage Editor Se lect
= NLA Editor Effact Strip..
*+" DopeSheet 4 Add 9 I mage
% Graph Editor
%% add an im
B
t oy o i

8 Timeline i e

T 3D View
L Dal =

Set to Video Sequence Editor Add image sequence (Video Channel)
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Step by Step: Compositing

) Blender* [CAU

BN AENAI ]

qe, (% 0043 tga (% 0086.tga 213 KB (% 0129tga 213KB = 0172.tga
{#]0001.tga 202 KB (%] 0044 toa % 0087.tga 214 KB (% 0130tga 214KB #0173t
5 oo02tga 219 KB = 0045 tga {#oosBtga 213 KB [H0131tga 215KB 017492
(% 0003tga 214 KB (] 0046.tga (% 0089.tga 214 KB (% 0132tga 215KB H0175.t0a
(% 0004.tga 217 KB (% 0047 tga (% 0090.tga 214 KB fH0133.tga 215KB (% 0176.tga
(% 0005.tga 216 KB (= 004 (% 0091tga 214 KB [H0134tga 215KE

@ 0006.tga 216 KB E| 0049.tga @ 0092tga 213 KB @ 0135.tga 215KB
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E| 0010.tga 216 KB E| 0053.tga @ 0096.tga 213 KB @ 0139.tga 213 KB

@ 0011.tga 216 KB E| 0054.tga @ 0097tga 214 KB @ 0140.tga 214 KB

fHoo12tga 216 KB = 0055.tga Ho09Btga 214 KB fHo141.tga 213KB
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{5 00z20.tga 216 KB (=] 0063 tga (H0106tga 213 KB (X 0149.tga 214KB = 0192.t0a
(% 0021.tga 216 KB (% 0064.tga (% 0107.tga 213 KB % 0150.4ga 212 KB #0193t
[Hoo22tga 216 KB (% 0065 .tga #o108tga 212 KB [H0151.tga 214 KB = 0194.tga
(% 0023tga 216 KB (% 0066.tga (% 0109.tga 213 KB (% 0152tga 215KB ] 0195.tga
[Ho024.tga 216 KB (%] 0067 tga f#o110tga 212 KB [H0153.tga 213 KB 2 0196.tga
[#0025tga 216 KB [ 0068 (#0llltga 212 KB [ 0154tga 214 KB

@ 0026.tga 216 KB E| 0069.tga @ 0112tga 212 KB @ 0155.tga 215 KB

[Ho027.4ga 217 KB = 0070.tga #o113tga 213 KB fHo156.tga 213KB

{fo028.tga 216 KB [ 0071.tga H0114tga 212KB %0157.tga 215KB % 0200.tga
fHo029.tga 216 KB = 0072.tga f#o115tga 213 KB #0158.tga 215 KB % 0201.tga
[#0030tga 216 KB # 0073.tga (% 0l16tga 213 KB f0159.tga 215 KB % 0202.t0a
(% 0031.tga 216 KB (% 0074 .tga (#0117tga 212 KB f0160.tga 214 KB % 0203.toa
[Ho032tga 216 KB = 0075.tga #o118tga 214 KB M 0161.tga 215 KB % 0204.tga
(% 0033tga 216 KB (% 0076.tga (% 0119.tga 213 KB F0l62.tga 215KB 5 0205
[Ho034.tga 216 KB #0077 tga fHo0120tga 214 KB f0163.tga 216 KB % 0206.t0a
[#0035tga 216 KB a (#0121tga 215KB f0l64.tga 214 KB % 0207.tga
(% 0036.tga 217 KB # 0079.tga (#0122tga 215 KB # D165.tga 215 KB # 0208.tga
50037492 216 KB i = o0123tga 215KB % 0166.tga 215 KB % 0209.tga
[F0038.tga 215 KB % 008 (#0l24tga 215 KB % 0167.tga 215 KB % 0210.tga
(% 0039.tga 216 KB 4 (#0125tga 215 KB % 016! 214 KB

(% 0040tga 216 KB 7 008 (% 0126tga 215 KB % 0169.tga 213 KB

(% 0041.tga 216 KB % 008 (% 0127tga 216 KB A 0170.tga 214 KB

(% 0042tga 216 KB (% 0128tga 216 KB M 0171.tga 212 KB

¥ Relative Path

This time, select all frames (Press A)



Step by Step: Compositing”

|
Drag the strip to the
“1st Frame” in Layer 1

O« sty |« ene2z0 - 1 KAAIS] 22| Nosy ¥ kg

Edit Video Layer (Right click and drag, left click to set)
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Step by Step: Compositing

=1 Select
s Add > Scene - Scene
| |

|« Endizzo ¢ M0 1 ¢ EEIE|<[S LD COIRETES — @il PR

Add scene layer

| »
Drag the strip to the

€

G o G G- Fnd: 210 COE D (el A o] 2] | o Sync v Y% L =7 -

Edit scene layer (Right click and drag, left click to set)
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Step by Step: Compositing

1 [ — €
You will o
Toggle Full Screen Ctrl Up Arrow p— . e L
Duplicate Area into New Window S e e t h e Replace

Properties
Panel

Select
0w View =2 Properties

Show Properties Panel

Select
Blend > Alpha Over

Set Blend Type
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Set scene camera to
“voodoo_render_cam”

Set scene camera

Select Premultiply



Check output setting again!




: Compositing

Change the viewing type

) 100 110 120 130 140

A vew e | ¢ TG CETTTED SEMREED, v
Preview your video




Step by Step: Compositing ™

& cine
& o
=
-
& Rad
&= TF

Select output format Press !
Finish !!

Back to flowchart
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More Examples

o CSIE Robot




ore Examples




More Examples -
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F A Q Digi\Y/ .4

VoodooE EiF |

- HENFERABEELK

— FZEtrackingiy75 =

BT EHEBlenderdi9BackgroundfFeature’R ¥ &

— FCEEERTE Cameras > Set Active Object as Camera

3D modelsiy I E/EN1F ...

— REHW!

- SAAHEZZHHNEDERATRAEREN, MERERE—LI5E

- E&I‘EEMEH%, SRR RAEINKEEM interpolation, Z&&—LE key
rames

STEREHLAKNEEZ Model 2&R97

- EES=ENEE

Faz =W 3D models

- WA LREERIFEZ!

— fIEn: http://www.3dm3.com/modelsbank/

http://www.sharecg.com/
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FAQ ——

File @] Help EE?EQEQE

Controls Ctrl+K R
Draw Options Ctrl+D VIeW 9 ContrOIS
Carmera Parameter Ctrl+P

Ctrl

30 Scene Viewsr

Madelling Tools Ctrl
. . Pevaimeter Settings Haxris Main Parameters
FPaint Track Editor Ctrl _ Set Default
Module on / off Mex. Comers: 900,000 [}
4 Detection W Enable Gamss Bigma:  0.70 D Rl
Harris ® Relative Min © 1.000e-05 0
DLineCorner O
Susan o Seale Factor, 0,04 [}
Foerstner O Ldaptive Parameters Flags
SIFT @) Windoew Size for Density: 32
4 Carrespondence An... ' Enable Atoimatically accept the tap: | GO0 [[] Adaptive
Cross Carrelation (O
i KLT Tracking ® ) D BB citase
SIFT Matching O ensity Thesh. : [ Dexiv. Gauss
Synthetic (@]
4 Outlier Elimination ' Enable Addibonal Parameters
Estimation depe... @ Win, Size for Local Maxe. 9
| _ © Deriv. Gauss Sigma: 1000 0
Translation o
F-Ilatrix o
Known Camera O
4 Estimation ! Enable
Rotation @
FreeMove O
4 Final Estimation W' Enable
Estimation depe... @
' oy [0 G




F A Q DIIVFX

e Use different views to adjust the positions and
poses of objects

| Camera
| view

view

Front
view

Set
view
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o Add lights
J Metaball

'ﬁ.,' Armature
IJJ Lattice
A Ernpty

==M)) Speaker

sSR!
Add > Lamp [t

=
o Camera

oiner

L. Force Field

A Group Instance

=

t_al

21 T )

3 Persp

& Sun
,f Spot
:‘H Hermi

iy
L Area

Add a lamp object to the scene




Document

o Blender official website
- http://www.blender.org/education-help/

e Voodoo document website

- http://www.viscoda.com/index.php/en/voodoo-
manual
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