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Setting

e Blender
— Version: 2.57a (stable)
— Operating System: Windows, Mac OS, Linux, FreeBSD
— Web Site: http://www.blender.org/

e Voodoo

— Version: 1.1.0 [More stable than before]

— Operating System: Windows, Linux

— Web Site: http://www.digilab.uni-hannover.de/
e Other Options:

— Free: Blender + ICARUS
— Pay: boujou + 3D Max, boujou + Maya, ...



http://www.blender.org/�
http://www.digilab.uni-hannover.de/�

Recipe: Get Image Sequence

Open Blender

Add Video File
— Change Window Type to Video Sequence Editor
— Select " Add - Movie |
— Drag the strip to Layer 1

Render Images
— Choose Render
— Choose output directory
— Frame
e Set frame size
e Choose output file type (Targa)
— Time interval = Select start and end of the sequence

Click Animation button
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Get Image Sequence : Add Video File

Change to Video
- Sequence Editor

Add - Movie

Click here to change window type



Get Image Sequence : Add Video File

Blender Render ¥

? ti . "—ﬁ’_E’_EF‘_i

m MzUODO51.MPG 2.6 MB

= M2ZLI00055.MPG 3.2 MB
m MzUOD058.MPG

Select video file

+ Relative Path

Start Frame: 53

File Directory




This is the sound track. Since we only need images
for feature tracking, you can choose to remove it
here, and add it back at the video editing stage!
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. Get Image Sequence : Add video file

Drag the strip to the “15t Frame” in Layer 1



_ Get Image Sequence : Render Images

Choose Render

Output directory

Select start & Choose output

end frame file type “Targa”

121 | Defwi_assigriggent3iwideo\M2U00052 . MPG
Choose frame size




Recipe: Calibration

Open Voodoo

Open Image Sequence

— Select ' File > Open > Sequence |
— Select the first frame

— Select Move Type ' Free Move |

Track — Click Track button

Export Python Script

— Select ' File > Save - Blender Python Script |

— Save .py file
* Choose File type “Blender 2.5x and higher (*.py)”



Calibration : Choose Sequence
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Save b Initial Camera Ctrl+1

Quit Ctrl+Q
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Calibration : Track

Track

9 Wa<dmprr» « booStat 1 End: 150 Skp 1 Track

C:/tmp/0024.tga - ONLY FOR NOMN COMMERCIAL USAGE
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Calibration : Track
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_ Progress

3 [¢d[«l[<) > )p) ¢ [ VoSt 1 Bad: 150 Stpr 1

r C:/tmp,/0004.tga - ONLY FOR NOMN COMMERCIAL USAGE

e = &=

14



Open
Save

Quit

2

Cirl+Q

Blender P!fthon Script

Maya Script
Softimage 3D[XSI
Textfile

CAHV Cameras
Feature Foints
SIFT Descriptors

Export 30 Objects

End:

1"'II

tr- II

Save - Blender
Python script




Cho se File type
“Blender 2.5x and

3D Max Script
Blender Python Script
Lightwave 3D

Maya Script
Softimage 3D[XSI

Look mn: [hD:'wfx_assignmﬂnB v] G a 0

ﬁ My Computer i || image_sequence =] 25.py
- . model_(Neo) Ghotic fountain @ io_import_voosloo_camera.py
a winale . Moonlight Powerpoint Template

. software
. video
=] 24.py

_i_

: @@]E]E][E]E] « = >|1;31m T [Bak 150 [8sn It Tl
|

16



Recipe: Import 3D Motions

e Open Blender

e Delete Default Objects
— Choose the object and click “Delete”
e Open Python Script
— Change Window Type to Text Editor
— Select ' Text > Open Text Block |
— Select io_import_voodoo_camera.py
— Click " Run Script |
— Select ' File > Import > Voodoo camera |
— Select the .py file exported from Voodoo



Recipe: Import 3D Motions

e Load Background Images:
— Change Window Type to 3D View

— Select ' View > Cameras - Set Active Object as Active
Camera |

— Load background images
— Set the video parameters of background images

— Change the view
* [ View - View Persp/Ortho |
e "View > Camera |
— Check 1st frame and adjust the opacity of background
images

 Load models & editing their motions in the video!



Import 3D Motions : Delete Default Objects

Click “Delete” to erase

Delete selected objects
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Import 3D Motions : Open Python Script

Text - Open Text Block

E= Uv/image Editor

= NLA Editor

** Dopesheet

2/ Graph Editor

Choose Text Editor

Change Window Type to Text Editor
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Run Python Script

bl | At (R Mo Sync




Import 3D Motions : Open Python Script

=) Blender

AT
B EERIEN---  CEEEe

Ctrl M

e you can redistribute it and/or
Open Recert... We GNU General Public License
L) re Foundation; either version 2
A W% Recover Last Session ion) any later version.

gt et 19 GIST the hope that it will be useful,
ut even the implind warrantv nof
SRl PARTICULAR F

Save As... Shift Ctrl 5 mare dEtEilS .

Save Copy... spiae of the GNU G File 9 Import 9

, wWrite to th

S RVETE NN s A Floor, Bosto Voodoo camera

Save User Settings Ctrl U
Load Factory Settings

COLLADA (.dae)

Mation Capture {.bvh) ipt from the Voodoo camera tracker softwar
Scalable Vector Graphics (.svg) S-Ti N AN

Stanford (.ply)
St (.stl)

3D Studio (.3ds)

Ph p-‘ m,,‘

Thi; script loads a Blender PythofiReCECUEUEr]
tra ker program into Blender 2.5x tclaYotetals A n Rl In )

= Voodoo camera uts' e

It | rocesses the script as a text
beca.-a of the incompatible Pytho




Import 3D Motions : Adjust Rendering

To avoid
rendering the
feature point
cloud in your
result




e

Cancel the
renderability of
the feature
point cloud

CEMes |
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Import 3D Motions : Load Background Images

Align View

Mawvigation

=] .
File Browser

@ Info

Ctrl Mumpad 3 Active Camera Murnpad 0

il User Preferences
Outliner Ctrl Murnpad 1
Front Murnpad 1

Bottorn Ctrl Mumpad 7

Properties

: Logic Editor
J Mode Editor
xt Editor

o Video Sequence Editor

Top Murmnpad 7

Camera Murnpad 0

B Tool Shelf
B Properties

0 4 iley #_ LA Global

View - Cameras - Set Active
Object as Active Camera

= Ui rmage Editor

= MLA Editor

’f’ DopeSheet

Ak

Change Window Type to 3D View
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Import 3D Motions : Load Background Images

Click the “+” or View -> Properties

All Scenes

e TETTTTT

= S MNurnpad 5

w22 L i
Ctrl Murpad 3
Right MNumpad 3
Back Ctrl Murmpad 1
Front MNumpad 1
Bottom Ctrl Murnpad 7
Top MNurmpad 7

Camera Murpad 0
Image Editor B Tool Shelf T
[F
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I"mport 3D Motions : Load Background Images

Tick off “Background Images” & Click " Not Set | , and then
click " Add Image ; on the menu Click " Open |

Image Editor
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Import 3D Motions : Load Background Images
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I'mport 3D Motions : Load Background Images

Set Frames: # images to use
Select ' Sequence | Start Frame : 1st

Tick off “Auto
Refresh”

w0000 | 0000




Import 3D Motions : Load Background Images

Align View Ali an Wiew

Mavigation
View Persp/Ortho MNumpad 5

Cameras
Ctrl Nurmpad 3 Ctrl Nurnpad 3
Right Mumpad 3

Back Ctrl Murmpad 1

Right MNurmpad 3

Back CtAl Nurmpad 1
Front Murmpad 1

Bottom Ctrl Murnpad 7

Frort MNurmpad 1
Bottom CtAl Nurmpad 7
Top Nurmpad 7 B el

Camera Nurmpad 0

B Tool Shelf
B Properties

= o

View = View Persp/Ortho View - Camera
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Import 3D Motions : Load Background Images

X:0.5199
Y- 0.5576
Z:-8.0171

You can adjust the opacity of
background images here

] =

( (1) Frame: 1 0~
< Sk

Check 1°* frame for om0
background images

tNe 1% BN @B - lasnns) annns
T 4

a7 i) (a5

ET-. T T T T s T T

Yol
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Import 3D Motions : Load Models

coencer (O,
B (W oerutt [ H|R
Tl New Ctrl N File > Import

= Open... Ctrl O
Open Recert... 9 “" M o d e I Type”

Recover Last Session
Recover Auto Save...

Save L

Shift Ctrl 5

Ctrl Alt 5

Ctrl AlL U

Ctrl U

Load Factory Settings

Link Ctrl Alt O

COLLADA (.dae)
Export Motion Capture (.bvh)
External Data Scalable Vector Graphics (.svg)
Stanford (.ply)

) Quit ctrl g

Stl (.stl)

3D Studio (.3ds)




Import 3D Motions : Load Models

To use the model as a “single
object” instead of many
“small components” (for

finer operations), you can
close the group options
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Import 3D Motions : Set Keyframes

I
Use
Object > Animation - ... Keyframe...
to set the motion of your model

Make Single User
Make Local...
Make Dupli-Face
Make Links...

Make Proogy...
Delete...
Duplicate Linked Alt IS

Delete Keyframe...

Apply Change Keying Set... Shift Ctrl Alt |

Clear

Mirror

Transform

Redo Shift Ctrl £

Lindo Ctrl Z
7l Opiectwoe ¢ [@ 2 % BB TME oou ¢ Jamenslennanl®:]




You can use
Object - Motion Paths - Calculate Paths
to see the motion path of models

-
i
5 g

% Time point of Keyframes D - i

. .Q:l 1[?:%@ Mo Sync




Recipe: Compositing

Add Image Sequence

— Change Window Type to Video Scene Editor

— Select ' Add - Images | and select all images
— Drag the strip to the “1st Frame” in Layer 1

Add Scene
— Select ' Add - Scene |

— Drag the scene strip to the “1st Frame” in Layer 2
Set Scene

— Change scene property to “Alpha Over”
— Set frame and video parameters

Click Animation



Compositing: Add Image Sequence

— MLA Editor

*+¢ DopeSheet
I . .
v Graph Editor d d a
B Timeline A Image
r 3D View '
) r : =

Change Window Type to Video
Sequence Editor
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Compositing: Add Image Sequence

2=} Blender

EsmE el

[D.’\le_assignmenﬂ\.i mage_sequencel,

[0150.ta

Select all
images

' Relative Path

1 Start Frame: 71

. End Frame: 96

. Channel: 1

v Replace Selection

T I i . | | | s
(8 . i
(. I . I | |
(. I . I | |




Compositing: Add Image Sequence

Drag the strip to the “1%t Frame” in Layer 1
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Compositing: Add Scene

Add = Scene = Scene

40



Compositing: Add Scene

Drag the scene strip to the “1st Frame” in Layer 2
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Compositing: Set Scene

View - Properties

]':I"I | Crana: Srano
Toggle Full Scregn Ctrl Up Arrow
Duplicate Area I§to New Window
Transforrm Markdis
Safe Margin
Show Frame Mufhber Indicator

Draw Frames

i |" 1A I._-. arts
View all Sequences Home

Select “Alpha Over”

Scene
Cross
Replace
Cross
Add

Subtract

BT
H 5

Alpha Lnder
Gamma Cross
Multiply

rer Crop




Compositing: Set Scene

Tick off “Premultiply”

Render Presets

Select "Voodoo render_cam”

v Premultiplhy
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Compositing: Output Video

You can change
“Sequencer view”
to "Preview" or
"both“ to preview

the result
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Compositing: Set Scene

Set “Start Frame” and Set video resolution, Frame
“(Video) Length” (time) range & Frame rate
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Compositing: Output Video

~ Erwironment

& emp @ Cineon [ el

& iris @ prx M aviPEG Ray Tracing

@ pnG @ MultiLayer (] AviRaw

@ jreG & openEXR i Frame Server Sky ¥

& Targa & Radiance HDR iT H.264

(& Targa Raw & TFF ¥ MPEG
ﬁ Theora

Color Manage

|
d
m AVI Raw ¥ File Extension

i"'l Xvi

BW RGBA Owerwrite

: Select output
Select output video type directory

= 19)



Compositing: Output video

T T
1/ . ".?"f?'i- 1

Click Animation! Example of Composited result
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Reference

e Blender
— Official website
http://www.blender.org/

— 2.57arelease log

http://www.blender.org/development/release-
logs/blender-257/

— 2.57a demo
http://vimeo.com/21780715

— Overview of 2.57
http://vimeo.com/22358302



http://www.blender.org/�
http://www.blender.org/development/release-logs/blender-257/�
http://www.blender.org/development/release-logs/blender-257/�
http://vimeo.com/21780715�
http://vimeo.com/22358302�

Reference

e Blender

— Basic video tutorial for 2.56 & 2.57 [17~8]
https://www.youtube.com/watch?v=WSj23GDGNil

— Basic video tutorial for Blender and Voodoo [Older vision]
http://www.youtube.com/watch?v=kPZbtKQla4g
http://www.youtube.com/watch?v=dREGzpAGKyA

— Older versions
http://download.blender.org/release/



https://www.youtube.com/watch?v=WSj23GDGNiI�
http://www.youtube.com/watch?v=kPZbtKQ1a4g�
http://www.youtube.com/watch?v=dREGzpAGKyA�
http://download.blender.org/release/�

Reference

Python problem between Voodoo and Blender

— Voodoo camera tracker and blender 2.57 fixed
http://Orz.tw/PqDVr

— Voodoo camera Import (io_import_voodoo camera.py)

http://Orz.tw/BNDm8

Voodoo document website
— http://Orz.tw/c2ceR



http://0rz.tw/PqDVr�
http://0rz.tw/BNDm8�
http://0rz.tw/c2ceR�

Reference

188 A Blender U & Voodoo 2R & 15¢ 18 e T

— http://newwork2000.blogspot.com/2009/10/blog-
post.html

K-Lite Codec Pack

— Mega http://Orz.tw/dfOm1

— Full, Standard and Basic http://Orz.tw/690HM
Video Editing Tools

- BIEE  BEER - .

— Sony Vegas, Adobe After Effects, Premiere, ...
Sound/Music Editing Tools

— Adobe Audition ( original cooledit ), Goldwave, ...



http://newwork2000.blogspot.com/2009/10/blog-post.html�
http://newwork2000.blogspot.com/2009/10/blog-post.html�
http://0rz.tw/df0m1�
http://0rz.tw/690HM�
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